Building sc3-plugins from source on Ubuntu Studio 18.04: "free(): invalid pointer"

Hello everyone

I could use a bit of help debugging an sc3 plugins install on Ubuntu Studio 18.04.

With no extensions added and no sc3-plugins, SuperCollider compiles and boots fine.

But with sc3-plugins installed (by compiling from source) the class library compiles, but the server exits as soon as I try to boot it. Most often with no message output, but sometimes with the “free(): invalid pointer” message and that the server exited with exit code 0.

I neither experienced this on Ubuntu 19.04 nor Manjaro 18 on the same computer so I am at my wit’s end here. Does aynone have ideas?

I am using SC 3.10.3 and tried both sc3-plugins 3.10.1 and 3.10.0

Hmm, I must have fucked up something in the build process. Removed everything and tried again with this script and it did the job

hey mads!

sorry if this is a bit offtopic but just saw this post and learnt about this build-supercollider fork.
does this fork provides an extra functionality that the original repo does not? if so, a PR would be more than welcome. I’m asking because so far i haven’t had any issues with the “original” repo and perhaps i’m missing something.

as a side note, a couple of months ago (was on vacations during october) i was working on building “automagically” deb packages for ubuntu 18.04+ using github actions, but only built debs for SuperCollider and not SC3-Plugins. have you tried this package? would you be interested in doing so?