Can't play Ndefs

Ndef(\test1, {

gives me the error message:

*** ERROR: SynthDef system_link_audio_1 not found
FAILURE IN SERVER /s_new SynthDef not found

what do I do?

Do you have some background of your issue? Was it working yesterday? Or did you come across this problem after upgrading to some version of SC?

Which OS?
Which SC version?
Which editor environment?

Have you tried rebooting scsynth? have you tried rebooting your computer? Have you tried checking you audio settings?

1 Like

OSX 10.13.6
SuperCollider 3.10.4
Supercollider IDE

The last time I used Ndefs was many months ago, so I can’t really tell if it had anything to do with updating. The only other information I have is that my .plot function also isn’t working.

Do you know what the error message might mean?


My startup.scd file had a faulty line of code in it. I removed it and now both the plot mothod and playing Ndefs is working!

1 Like

nice. good to hear you figured it out.

out of curiosity what was the syntax error / faulty line ?

and why could it be that SC did not complain on boot?

damn I actually didn’t post or save it anywhere, so it’s gone! hehe

from the plot-post: