Error building SC on Raspberry pi3


I tried to search if there would be a similar problem but I couldn’t find any results.

I am having trouble setting up super collider on Raspberry Pi3. I am following the instructions from here:…/su…/blob/develop/

But I am running into error with both gui and guiless build.

First I am getting this error message:

"[ 57%] Built target libscide

make: *** [Makefile:163: all] Error 2"

Then after I have reboot the RSP3 and try without -j 3 as recommended I start to get this error:

"[ 55%] Building CXX object editors/sc-ide/CMakeFiles/SuperCollider.dir/core/main_function.cpp.o

/home/pi/supercollider/server/scsynth/SC_World.cpp:60:32: warning: extra tokens at end of #ifdef directive



/home/pi/supercollider/server/scsynth/SC_World.cpp:61:14: fatal error: xmmintrin.h: No such file or directory

include <xmmintrin.h>


compilation terminated.

make[2]: *** [server/scsynth/CMakeFiles/libscsynth.dir/build.make:258: server/scsynth/CMakeFiles/libscsynth.dir/SC_World.cpp.o] Error 1

make[2]: *** Waiting for unfinished jobs…

make[1]: *** [CMakeFiles/Makefile2:2659: server/scsynth/CMakeFiles/libscsynth.dir/all] Error 2

make[1]: *** Waiting for unfinished jobs…

[ 55%] Linking CXX executable scide

[ 55%] Built target SuperCollider

make: *** [Makefile:163: all] Error 2


Anyone who could help me with this one?

Hey @jukkapoika – I don’t have access to an RPi so I can’t test this – can you try editing that line in SC_World.cpp to:


and retry (you should only need to run make scsynth)?

Thanks @VIRTUALDOG for quick help. Editing the SC_World.cpp worked. So SC is up and running on my RPi!