Error: VSTPlugin + M1

I recently built VSTPlugin on an M1 MBP and am encountering this error message when trying to open the ENTTEC DMXIS vst:

ERROR: PluginBridge::pollUIThread: plugin 1 doesn't exist (anymore)

When freeing VSTPluginController’s synth I also get WARNING: read(): EOF, which is likely related…

I haven’t had a chance to test with the DMXIS hardware yet, but I’m assuming this is going to cause some problems at my rehearsals next week…or? The DMXIS vst is outdated so I’m guessing the problem lies within the vst itself, but any insight from this community is very much appreciated! :slight_smile:

These error messages are harmless. As long as the plugin itself works, all is fine.

If you have time, can you try the following development snapshot and see if you still get the same errors/warnings?

1 Like

Thanks for the reassurance @Spacechild1! :sweat_smile:

Happy to try out the snapshot you sent along - though it looks like it’s only Linux and Windows builds? I’m on macOS 12.6 :apple:

Ah, there has been an error in the CI pipeline. Here you are:

Thanks - I’ll try to have a report on your desk by the end of next week! :slight_smile:

Using the snapshot you sent along, I still get the first error (plugin 1 doesn't exist) but the second error didn’t appear.

The VST seems to work as expected however, which is a relief! :slight_smile:

Thanks for reporting back!

Can you show the exact code that triggers the error?

These steps reproduce the error (though in my setup they’re in side a routine inside a class, etc.)

// triggers ERROR: PluginBridge ...
		\, 1))

v = VSTPluginController( Synth(\dmxis) );"DMXIS-Inst.vst");

// triggers WARNING: read(): EOF
1 Like