How to avoid issue with `ssh` run with `.unixCmd`?

I have just encountered a rather particular bug: "ssh user@host".unixCmd messes up sclang’s AppClock, and thus GUIs. Anybody else encountered this? Any ideas how to get around it?
.runInTerminal seems to be one option, but then there’s no way to know when the command finishes, which is rather important in my case.
For reproducers see

Answering my own question here:
It seems that running the command inside "bash -c '<ssh.... >' &".unixCmd is a workaround for this. I’ve added more information in the linked issue.