Manta on macOS 12

Hey all, kind of a long shot, but wondering if anyone out there has a Manta and is successfully using it with SC on macOS 12.

I recently upgraded from macOS 10.14, I’m now on 12.4. Now, the following code now returns a different number of HID elements than it used to. I confirmed this by checking with an older computer still running 10.14, using SC 3.12.2 in both cases. On the older version of macOS, SC sees all 66 of the Manta’s HID elements. On 12.4, it only sees 4.

I’ve been in touch with Jeff Snyder, who confirmed the Manta Max object is working as expected on macOS 12. I was also able to establish full HID communication between SC 3.12.2 and a PlayStation4 controller on macOS 12.

So, I pretty much have no idea what’s going on. If anyone has any insight or ideas into why this discrepancy might be happening, I’d appreciate the info.

~mantaInfo ={ |n| n.vendorName == "Snyderphonics" }).at(0);

~manta =, ~mantaInfo.productID, ~mantaInfo.path);

e = ~manta.elements;

e.size; //returns 66 on macOS 10.14, returns 4 on macOS 12.4

My GUESS here is that it’s a permissions issue - USB devices have always been a pretty open vector for attacks / data theft, so it would not be totally surprising if Apple has started to lock down access to some types of HID elements if an app has not requested explicitly. I would suggest trying to check this will a properly signed official build of SC (if you’re not using one already), make sure you’ve added the app to the right access lists in Security and Privacy (especially Accessibility - this might apply to the HID elements?).

Unfortunately, I don’t have any idea how to properly triage “silent” permissions failures like this (if it is one…). I have a long-open question on Stack Overflow with exactly zero answers on this topic, so probably nobody knows how to do this… Maybe there’s something showing up in the logs in Console?

This happened to me with the Nintendo Switch controller. I spent all this time making the Modality Toolkit driver, but now I can’t get the HID data off the controller any more with the recent OS’s. This would be a super drag with the Manta. Have you tried using MantaOSC in the app or command line versions? Not sure if that still works, but it opens up on my computer at least.


Thanks both.

I did, when I first got the Manta. I can’t really remember how well it worked, but I remember deciding that using HID directly in SC seemed easier and more straightforward. I’ll revisit MantaOSC and see if that’s still an option for me. Haven’t messed around with command line tools but appreciate the tip.

This was my hunch too. Weird that the Manta Max object apparently works on macOS 12, but it might be designed totally differently.

For the record, fixing this issue is not a top priority for me at the moment — I can work around it. Just asking on the off-chance there happened to be a quick fix.