RTWavesets Ugen problem

Hi folks, this problem drives me crazy: I am unable to use the Fabian Seidl’s RTWavesets plug-in (which seems exciting!) cause I got this error message:

exception in GraphDef_Recv: UGen 'WavesetAnalysis' not installed.
*** ERROR: SynthDef wstest not found
FAILURE IN SERVER /s_new SynthDef not found

The problem is that

  • I don’t think that I made mistake while installing the plug-ins (classic installation in extensions folder / recompilation etc, I never had problem before with that)
  • SC recognises all the other RTWaveSets plug ins contained in the same folder, and the WavesetAnalysis Ugen is also there, as it has to be

Here’s the link:

And here the code example that I run when I get this error message:

Server.killAll;

(
var wsData;
s.waitForBoot{
	/*
	b = Buffer.read(s, "soundexample.wav",0,-1);
	*/
	b = Buffer.read(s, "soundexample.wav",0,-1,r);
	wsData = WavesetData();
	//NdefMixer(s);

};

r={

SynthDef(\sound, {	PlayBuf.ar(b.numChannels, b.bufnum, BufRateScale.kr(b.bufnum), loop: 2); });

x = SynthDef(\wstest, {
	arg repetition=10, groupSize=10, rate=1, desiredDur=(1), desiredRMS=(-1), analysisOn=1;
	var idx, out, trig;

	WavesetAnalysis.ar(wsData, PlayBuf.ar(b.numChannels, b.bufnum, BufRateScale.kr(b.bufnum), loop: 2), analysisOn).poll;
desiredDur.poll;
		desiredRMS.poll;
	trig = Dust.ar(10);
	idx = WavesetSelector.ar(wsData, 0.1, -1);
	WavesetGetFeature.kr(wsData, \rms , idx).poll(label:"rms");
	WavesetGetFeature.kr(wsData, \dur, idx).poll(label:"dur");

	out = WavesetSynthTriggered.ar(
			wsData, trig, idx-groupSize+1,  rate, groupSize, repetition);
	Out.ar(0,out);


}).play;


}
)

x.set(\desiredDur,-1);
x.set(\desiredRMS,-1);

If someone could try this and help me I would be really gratefull!
Thanks

Hello Raphael!

I am on SuperCollider 3.10.4 Mojave osx. For me it works “ok” (I think this UGen is pretty glitchy), with almost no warnings, and display lots of messages like this:

-> a Function
UGen Array [0]: -1
UGen Array [1]: -1
UGen(OutputProxy): 1
UGen(OutputProxy): -1
rms: 0.0163093
dur: 0.000748299
UGen Array [0]: 0
UGen Array [1]: 52
UGen(OutputProxy): 1
UGen(OutputProxy): -1
rms: 0.0421007
dur: 0.00721088
UGen Array [0]: 0
UGen Array [1]: 120
UGen(OutputProxy): 1
UGen(OutputProxy): -1

Due to you postwindow message it seems that you did something wrong when installing. I guess that you haven’t compiled it, right ?

Have you noticed that this github repository does not have any .scx file but only .cpp, .h and .scd files ? This means the the author is only providing the source code, you will need to compile it based on your OS. If you are on mac, I know how to compile and it is doable. If you are on linux it is probably the same as on mac. If you are on Windows, I am not 100% sure if it will be possible, because it depends on cmake file that Fabian provided.

If you have compiled it, try checking if the RTWaveSets folder structure is similar to other plugins installed on your plugins directory.

All the best,
Fellipe

Thanks Fellipe. Oh I didn’t notice that there was only .cpp, .h and .scd files… I am also on Mojave, can you give me the steps to compile it ? I tried to look online but it’s quite confusing to me.
Thanks a lot.

As RTWaveSets is hosted by Till Bovermann, for more infos you might want to ask him directly or on the SC mailing list.

As soon as I have more time I will post the recipe here, but in the meanwhile try compiling it like the compilation recipe provided on SuperCollider Plugins homepage (section Compile from Source)