[solved]When using the Atk command, "ERROR: Class not defined" is displayed

OS: macOS Catalina
SuperCollider: 3.10.3

I tried the following commands.


I confirmed that the following folders exist.

~/Library/Application\ Support/SuperCollider/Extensions/SC3plugins/ATK

Then using the ATK command, I got message “ERROR: Class not defined”.

Is there any way to resolve this issue?

there’s no ATK class - (the main classes in the toolkit are FoaEncode FoaTransform and FoaDecode).

in the help you should find a guide ‘Introducing the Ambisonic Toolkit’ which will walk you through the typical usage!

There is a class called Atk, which is “a class that stores some global variables for the Ambisonic Toolkit”. Is this what you’re looking for?

This will return the path to the user support directory:


Hello @semiquaver, actually, this guide has been replace by: ABCs of the ATK

@mynkit, the installation instructions are here.

it is also case sensitive - ATK and Atk are different things to the interpreter

Maybe this is useful to know as well: after installing quarks, you must also one time recompile the class library.

A easy way to do so is to quit scide and restart it; other ways are to type ctrl+shift+L in scide or to use the “Recompile Class Library” in the Language menu of scide.

Many thanks!!
After restarting SuperCollider, I ran the following command and it worked.


A post was split to a new topic: Atk: thresh2 not understood