3.12.0 Final Release

We are pleased to announce the release of SuperCollider 3.12.0! The release is available here: Release 3.12.0 · supercollider/supercollider · GitHub

CHANGELOG.md contains a more extensive list of changes. Notable improvements in this version include:

  • Supernova is now available on Windows
  • Supercollider is officially supported on Bela platform
  • macOS Big Sur is now fully supported
  • On macOS output signal won’t go over the system volume level
  • The method not found error in sclang now provides suggestions, using fuzzy array comparisons
  • Oppressive terminology has been updated throughout the project
  • CI has been updated to use GitHub Actions and now also runs our test suite

Big thanks to everyone who contributed to this release!

Marcin & Josh


Thanks a lot dev team!!!

Bravo !!! and some more characters

Thanks a lot !
What’s the difference between https://github.com/supercollider/supercollider/releases/download/Version-3.12.0/SuperCollider-3.12.0-win64.zip and https://github.com/supercollider/supercollider/releases/download/Version-3.12.0/SuperCollider-3.12.0_Release-x64-VS-028ff1b.exe ?
Best regards

One is the installer, and the other is a self-contained version of the program.

Congrats and many thanks!


Good to know, thank you !

I’m officially aroused. :wink: Thanks for all the work.

1 Like

Hi again,

I’ve had problems installing and running the “SuperCollider-3.12.0-macOS-legacy” build on my laptop. The readme doesn’t say what the minimum requirements are, but I’ve been using 3.11.2 on that machine without problems:

MacBook Pro (15-inch, Late 2008)
OS X El Capitan Version 10.11.6
2.4 GHz Intel Core 2 Duo
8 GB 1067 MHz DDR3

Firstly, I was unable to mount the DMG:

Screen Shot 2021-08-05 at 04.39.22

It did mount on my newer studio computer, so I copied the files over.

But whenever I launch the app, I get this error in the post window:

Interpreter has crashed or stopped forcefully. [Exit code: 5]

I’ve renamed the previous App Support folder, so as far as I can tell, no extensions or quarks are being loaded. Maybe my laptop is too old. Any ideas?


Thanks @creator31, this is useful information. The DMG issue is unfortunate, but should be easy to solve. However, the interpreter crash is worrying. Would you mind attaching a crash report? You can find it in Console.app under User reports → sclang (or SuperCollider).

EDIT: Does the IDE itself start?

Hi @MarcinP, thanks for the reply. Hope it’s not too worrying!

The IDE does start. The error message is printed in the post window. I can also type into the code window. When I try to manually boot the interpreter using the menu, I get the same error in the post window.

I’ve zipped up the crash log but I’m unable to attach it in this forum. I don’t want to post it all here. Can I send it via email (via PM), or something else? Sorry, I don’t use github.

Thanks again, Marcin.

@creator31 could you try this build?

If it opens, please also test if opening audio files (SoundFile class and Buffer.read) works fine.

Hi @MarcinP. Thanks for that. Fast work.

The DMG mounted ok, and SC 3.12 managed to launch. I tried the first help file examples for both Soundfile and Buffer.read. They seem to work ok.

There were a couple of weirdnesses though (but these could be because it was a test build?):

  • OSX complained the app was from an “unverified developer”. I could open it via a right-click menu, though.
  • Opening time was very long (about 30-60s).
  • The help file code examples are rendered using something like Times New Roman. Yuk, but not so important.

But yes, it’s running on my old laptop. Thanks for working on it. :smile:

EDIT: I just tried again and SC opened in what I’d consider normal speed. All good.

Great, thanks for testing!
Now I know what the fix is for this. It might take some time to iron out technical details about it, but it looks like a good candidate to be included in the 3.12.1 bugfix release.
As for “unverified developer” - yes, that was to be expected. Only our regular releases are signed (so this won’t be an issue when this fix gets into actual release).
Not sure what’s up with the font though. If that problem is still there in 3.12.1 maybe it’s something to report… but likely not something we’d have much time to work on.

Excellent! No worries about the font. Thanks again.

I am also having problems with the downloaded dmg file from Github on macOS 10.13. I can run code in 3.12.0 within the mounted DMG file. But, when I copy it onto my harddrive macOS tells me the file is damaged and do I want to move it to trash and won’t run.
Computer spec:
MacBook Pro (13-inch, Early 2011) running macOS 10.13.6
2.7 GHz i7 + 16 GB RAM + 500GB SSD

I have download the legacy zip supplied above and this works within the DMG and when I copy it to my harddrive. @MarcinP Many thanks for providing the new package file.

Hi @mint,

Was your error actually saying the file is “damaged”? The download worked ok for me. But I did get this:

Did you try that?

But, the above download is a test build, as far as I know. Not really for production. I tried it and it worked, but I’m holding off until there’s an official release. No big hurry for me.

Good luck.


The build posted above is really similar to 3.12, but 1) with corrected DMG format and 2) with our own build of libsndfile library. So the only thing that’s potentially different has to do with loading sound files. Otherwise it should be as stable as 3.12.

While the build above was from my attempts to fix it, this has been now merged into the 3.12 branch and you can grab a build from there:

macOS legacy build

Please note, it’s still “unsigned” (only our releases are), so you need to right-click → open to have the option to actually open the app on the first run.

Hi @creator31,

It did say damaged. I double checked this morning.
Screen Shot 2021-08-14 at 09.15.30

I even downloaded the legacy the signed DMG from Github and got the same error! What is wierd is the unsigned test build runs and the signed 3.11.2 DMG installs and runs, so its just signed 3.12 I am having a problem with.

Starting to wonder if its my laptop’s macOS install :grimacing:

@mint can you confirm that the legacy build posted here works fine for you? If so, then the fact that the unsigned build posted here runs is not “weird” - it was explicitly fixed to address the compatibility issues. At some point we will likely release 3.12.1 which will include this fix.