ASIO bad times. For windows users. HELP!

SOLVED

Hi everybody.
I’m new to windows, I was working with SC on mac before. I’m still practicing with audio and today I had this problem : I’m using a RME fireface 802 audio interface, and I wanted to use my many inputs inside SC version 3.11.2 (as I always did well with mac). I wanted to use ASIO4ALL in order to create an aggregate device, but I didn’t succeeded due to drivers problems and lack of wifi. So, when I plug my RME, SC sees it but in the format of -going by memory- “booting with RME Fireface 802, In: Fireface 802 (ADAT 5/6), out: Fireface 802(Analog 1/2)” …seems that if I go on audio preferences, I see the RME but I must choose between a pair of channels for IN and same for OUT. And when I change these settings, and reboot SC, it boots with same channels I’ve just changed in the windows audio options. The question is : how can I tell SC to grab all the channels from the RME like one does with mac? Normally with mac you just plug the interface, or set in audio/MIDI options, or even select it inside SC, and every channel is at your disposal. On windows 10, not, to my experience. Should I do a kind of s.options.device = " the number of device listed that reports 30 ins / 30 outs " as it is listed when SC boots ?

Could please someone clarify me? By the way I updated the drivers of the RME and should check again. And, in Reaper I could see every channel form the RME using ASIO…is it an issue of this SC version?
Many many thanks

Leo

In recent versions of SC, you should be able to set inDevice to the “channels in” entry and outDevice to the “channels out” entry.

http://doc.sccode.org/Reference/AudioDeviceSelection.html#Windows

hjh

I use SC 3.11.2 on Windows with my ASIO sound card without any problem.

RME sound cards have very good drivers, I would use the RME Asio drivers, not the Asio4all ones.

Here is my startup file

Server.scsynth;

s.options.device = "ASIO : Yamaha Steinberg FW ASIO"; // change this to RME
s.options.numOutputBusChannels = 8; // change this to the number of inputs of your RME
s.options.numInputBusChannels = 8; // change this to the number of outputs of your RME
s.options.sampleRate = 96000; // choose your preferred sample rate

s.recHeaderFormat = "wav"; // better than aiff on Windows
s.options.memSize = 65536; // not related to the sound card
s.options.numWireBufs = 512; // not related to the sound card

s.waitForBoot({
	s.makeGui; // boot the server after sound card selection
});

Good luck !

Geoffroy

Hi and thank you,

not sure I understood…shouldn’t I do :

s.options.device = “ASIO : Rme Fireface 802” ;

I don’t intend to use one device for in channels, and another one for out channels…

leo

Hi and thank you,

Now I have updated the drivers from RME website, so I’ll try this evening. I wanted to use ASIO4ALL only for the purpose to create an aggregate device and expand my I/O, but is not strictly necessary for now. Or do you know another way to create an aggregate device without ASIO4ALL ?

Another posible issue : I can’t see the Universal Asio driver in the device manager, under audio inputs and outpus. I found on the internet that it should be visible, or maybe it will when the interface is plugged in…do you see it? Are you on Windows 10?

Do you think that the problem can occur because I set the interface not from the startup file ? I don’t think so, but who knows…I’m not a very informatics guy hehe!

Many thanks

Leo

You might be confusing your single hardware device with the virtual device(s) that Windows uses to represent the hardware device.

Windows quite often represents a single device as two lines (one for input channels and the other for output channels). They still point to the same hardware device, but you may have to set inDevice and outDevice to different values even though it’s the same hardware. (Is that confusing? Yes… but, blame Redmond.)

You’ve so far avoided posting concrete details, so it’s hard to be more specific. I’d really recommend copy/pasting the text from the post window. Otherwise it’s guesswork.

hjh

I can’t see the Universal Asio driver in the device manager, under audio inputs and outpus. I found on the internet that it should be visible, or maybe it will when the interface is plugged in…do you see it? Are you on Windows 10?

I am on Windows 10 but I don’t have a RME interface. If I were you, I’d uninistall Asio4all, update the RME drivers, and start with the line

s.options.device = “ASIO : Rme Fireface 802” ;
s.options.numOutputBusChannels = 8; // change this to the number of inputs of your RME
s.options.numInputBusChannels = 8; // change this to the number of outputs of your RME

before booting the server.

As far as I know, there’s no inbuilt equivalent of Mac agreggate devices on Windows.

Good luck

geoffroy

Ok, I understand now…and, yes, passing from mac to windows it’s confusing moreover as I’m not expert in informatics !

You’re right, I didn’t post any code cause I don’t have my intereface now. I’ll check later.and see how it goes.

Thanks a lot for helping!

Leo

is because some conflicts could take place?

thanks

Thanks A LOT!

Everything works now. I’ll see if the problem was linked to asio4all, as well as I probably did something confused in the procedure. Or the old driver… Don’t know.

Many many many thanks!

Leo

Glad it worked in the end. Happy coding !