Audiovisual jazz project. SC in Linux. My experience so far and questions

So. I have Installed Ubuntu as a dual OS in my 3900X/64GB/1080ti based machine.

My experience has been for the most part great :slight_smile: I can say I really like Linux.

I needed to use KDE so my 4 monitor setup worked fine. It’s a misaligned mess in gnome and I also had it’s UI to be unresponsive for as long as 10 or 20s very often. KDE is not only way more friendly coming from windows but also solved all those problems.

So. SC in Ubuntu using KDE, while works when I tried my code made in Windows. I still have a problem.

SC is very, and I mean very, unstable when it comes to moving docks around. If I undock the documentation panel, and move it a single pixel, SC poof crashes immediately without any warning.

I had often SC to not load at all. Or take up to 1min to load up after the moment I launch it. I had multiple SCs instances opened after 1min from the moment I clicked the icon about 3 times thinking SC wasn’t loading.

When I got to try my Giant Steps visuals (coded in Windows10), it ran surprisingly good, especially scsynth was using nearly half the CPU as in windows 10. Sclang on the other hand, while working quite good, the animations ran a tad slower than in windows, at a lower framerate, signs of a not as well optimized system when it comes to graphics as compared to windows.

Project here:

I could install v430 and v450 of Nvidia’s linux drivers, KDE’s UI is very smooth so I think they’re working. Haven’t tried any 3D program though.

So I’m curious to hear what your first hand opinions are.

Now, the actual questions are:

  • Is there a Linux distro that is hands down right for SC?

  • I saw there’s something called Linux AV? Is it any better when it comes to sound drivers? or does it have an advantage?

  • Can I just install another Linux over my existing installation? Or should I better reformat the partition?

  • I saw someone mentioned the Stanford lab uses a " yum repo for Fedora ". IS it any good? The post is from 5 years ago.

  • I have trouble getting my realtek inbuilt card to be visible to use as system sound. I can see it in the ALSA Mixer and appear to have the right controls and also nothing is muted. But my speaker icon on the taskbar has an X and I can’t see any device in the options.

  • I’ve read about solving it by changing which audio device gets initialized with Linux and I have made the appropriate conf file that I need to paste in my /etc folder.

I needed permission so I ran the appropriate command and had the hashtag after my username in Terminal. Even so, I could not paste my conf file into the etc /folder and the system said I needed admin permissions.

Thanks to everyone in advance.

I’ve been using Ubuntu Studio. It uses the XFCE desktop, which is years behind other desktops’ UI innovations but it’s also more lightweight and faster.

You do have to do some extra configuration to get JACK audio (for scsynth) to play nicely with PulseAudio (everything else). I’m not sure if that’s your specific problem though.

A superuser command in a terminal window will apply to that terminal session only. It isn’t global for every window. (The file browser is a separate process from the terminal.)

You’ll have to run the file browser as superuser from a terminal: find out the executable name of the KDE file browser and then sudo that_command which should pop up an administrator-level file browser.

Or – probably easier – if it’s one file, use sudo cp source_file_path copy_to_path in the terminal.

hjh

Hmm…that clarifies things a bit. I thought for the system I needed to deal with ALSA, PulseAudio is something I wasn’t sure what it was. Thank you. I’ll see about that.

I though Jack was like ASIO (scsynth) in windows and ALSA like DirectX (system sound). In windows ASIO is never used for the system sounds, and though it was the same case with Jack.

I can open, configure and turn on Jack, I can also boot scsynth using Jack with my presonus iTwo interface. I just want to be able to use that card, or an inbuilt Realtek card I have as well for the system sound to be able to hear sound from FireFox.

EDIT: Forget all that. I just booted again into Ubuntu and now I have system sound. No idea why it wasn’t working then.

Hmmm…is defaulting to one of my Firestudio cards actually. And is one of the least unlikely to work. Anyway…it makes sound so I take it.

I also have two Presonus Firestudio Project interfaces, Linux sees them, didn’t try Jack yet.

Thanks again, very helpful.

I do use LXDE personally, which is lightweight, but I’m a pretty experienced Linux desktop user. KDE should do, many people use it, also for audio.

AVlinux has JACK configured, it’s mostly a Ardour DAW focused distro. Ubuntu Studio should do as well, but I’ve never been a fan of it, I didn’t use it in the last 5 years or so, so take this with a grain of salt.

I do recommend to use the ‘quickscan’ configuration script here:

Leaving out the hardware timers stuff.

The app cadence might be a easy way to deal with pulseaudio and JACK. Lot’s of people also using Qjackctl and a2jmidid.

You might want to add the Kxstudio repositories to your system:
https://kx.studio/
https://kx.studio/Repositories

Audio configuration is a bit more difficult on Linux, compared to Windows/OSX probably.

https://linuxmusicians.com/ is a pretty good resource.

Thank you. I got all working but I’m always interested in learning new things in Linux.

I’ll take a look at quickscan and kx.studio

I’m not using Linux (yet), but I just wondered, since everyone mentions JACK, if anyone has tried BlackHole yet? I know that this is actually the SoundFlower alternative, but I’d be curious to know how it performs with Linux? And, you never know, maybe it would be a suitable replacement to solve your problems too.

Hello jamshark70!

What is you’re extra config in Jack to get it running with PulseAudio?

For me SC in Ubuntu Studio works ok, it crashes only on long sessions or with silly code. Lately I had a permanent installation, It crashed on average every 3 days. My usual suspect is Jack, but I’m not sure.

Under Linux I don’t get the load relation between SC and Jack. Launching heavy stuff, Jack is sweating as well. Under OSX all the load seems to be indicated in the serverloaddisplay (the green numbers, lower right).

On Raspberry with Prynth, Jack crashes before SC with heavy load.

https://jackaudio.org/faq/pulseaudio_and_jack.html

SC’s load comes directly from JACK. In fact, that’s the relevant figure: It would be misleading for SC to say it’s using 5% of CPU time when the aggregate over all running JACK apps is 60% (because, in fact, at that moment, you are in danger of overloading the CPU).

JACK’s CPU load figure must include all running apps. So yes, if SC is doing a lot of DSP, JACK must report this as well.

SC-IDE in Linux displays this as well (it always has for me, for years).

hjh

I’ve a well performing JACK, so with the right system tweaks that’s perfectly possible and to be considered normal.

Afaik RPI-4 has problems with it’s hardware for audio and so JACK I’ve heard.

All depends also on the settings of JACK. If those are tight it will ask more resources from your system.

More info:
https://wiki.linuxaudio.org/wiki/system_configuration (sometimes a bit outdated probably, focus on the quickscan script).
https://manual.ardour.org/setting-up-your-system/the-right-computer-system-for-digital-audio/