Disable default instrument for Pattern playback

Got some weird behavior I’d never seen before…
Working on a piece with a bunch of patterns controlling an orchestral library in Ableton Live, sending MIDI data via LoopBe internal MIDI cable (Windows). For some reason, when working on this today, SC was playing the patterns on the default instrument (cheesy piano sound) alongside the MIDI notes I could hear in Ableton. This happens even when I don’t boot the server! Any ideas why, or how to get it to stop? Never happened before and I have no idea why it started. My code is very simple; many copies of the most basic patterns:

		\type, \midi,
		\midiout, MIDIOut.newByName("LoopBe Internal MIDI", "LoopBe Internal MIDI"),
		\chan, 0,

		\midinote, 60, //etc
//and so on

If I set the \instrument key to nil, for example, I get no MIDI notes in Ableton. But this piano sound is driving me crazy. Thanks for any advice.


Then it definitely isn’t SC playing the piano sound (although the \midi event type should be ignoring the \instrument key… that puzzles me).

Setting \instrument, nil forces the pattern to stop immediately – so, not only is it not playing notes, it isn’t even generating note data in that case. nil in patterns means “stream is over” – you can’t clear a key that way.

I’d check to see if there is some other MIDI player that might be responding to the messages, in addition to Ableton, or maybe a new track in Ableton.