Encounter an 'interpreter has quit' error - but `sclang` works well in command line

Hi all, it’s my first post but I’ve learned a lot from this forum, and thank you for reading this!

My question:

  • SuperCollider posts this once opened: [Interpreter has quit. [Exit code: 0]].
  • Interestingly, I can successfully run sclang in command line, after manually adding the $PATH$ to .zshrc file.

Device / System:

  • MacOS Sonoma 14.4.1

Context / Reproduce(?):

At first I can run SuperCollider smoothly, but after the uninstall & reinstall, this error occurs.

  • I uninstall the supercollider by moving /applications/supercollier.app to trash.
  • I install / reinstall the supercollider with the pre-compiled version, 3.13.0 universal binary.

I know we have several similar topics here, for example I tried to add $PATH$ to both .bash_profile and .zshrc, according to this thread, but unfortunatly the error still exists.

Any crash reports in Console.app?


1 Like

Hi jamshark70,

Thank you for your reply. Nope - only this one line of text, “Interpreter has quit. [Exit code: 0]”, and still the same text if I click the boot interpreter. I doubt it’s related to the $PATH or something…?

Problem fixed - when incompletely uninstalled, it might be useful to delete /Library/Application Support/SuperCollider folder and reboot the app.