ERROR: CMake is not installed


I’m trying to install the portedplugins via ‘Plugins.Gui’, but I get this error.

-> Plugins
cd "......Library/Application Support/SuperCollider/pluginpackages" ; 
git clone --recurse-submodules
ERROR: CMake is not installed

I have installed CMake via the dmg. file on their website. Is there anything else I need to do to get CMake to work within SuperCollider?


Follow the instructions here: Installing | CMake

I’ve downloaded exactly as instructed and have CMake running in command line. However SuperCollider still gives me the
ERROR: CMake is not installed

Oh, then it’s probably something to do with SC’s PATH or the PATH it sets for its subprocesses. I would honestly just recommend uninstalling CMake and reinstalling it thru homebrew; that would require the least manual configuration.

Okay, thanks.

Should homebrew install CMake on the correct path, so that SC can access it?

Yes I’m pretty sure. It’s been awhile since I did this on mac but my understanding is SC as a desktop application is started with a limited PATH that has a few things like /usr/bin, and homebrew installs (or places symlinks in) one of those paths. As a desktop app started through the system launcher SC won’t have access to environment variables you set in .bash_profile etc.

Reinstalled CMake with homebrew, which places it here /opt/homebrew/bin/cmake

But I still get the same error in SC. Which says CMake is not installed.

Is there anyway I can direct SC to the CMake path?

Weird, @madskjeldgaard might know more.

I would add /opt/homebrew/bin to the PATH variable from within SC using setenv and getenv - String | SuperCollider 3.12.2 Help. You can also use that to see what PATH currently is. This could go in your startup file.

  var path = getenv("PATH");
  if(path.isEmpty.not) { path = path ++ ":"; };
  setenv("PATH", path ++ "/opt/homebrew/bin");

Ah brilliant. That did the job (ignore deleted message about code error).

Thanks a lot!

1 Like