Exception in World_OpenUDP: bind: Address already in use

–SOLVED (workaround) see post 3–


using SCNvim and Mac Catalina (and VSTPlugin in case that is contributing)…

in the past when I’ve gotten these I’ve had to search and rm a file called “sc-pipe” that SCNvim creates - but now in Catalina - no dice.

pkill scsynth Server.killAll not working either

any ideas?

there’s some interesting discussion here on force resetting UDP ports which might help

update: able to launch scsynth from terminal if I specify for example -u 6666

q: does anyone know the default port? -Update found it 57110

maybe I can get SCNvim to choose a different port

SOLVED! can change the port with s.addr=(NetAddr(“”,6666)) then s.reboot

One safety tip here: If you have a server up and running, and you want to switch to a different port, the sequence you wrote would leave you with two server processes, not one.

// let's say I have a server on port 57110

s.addr = NetAddr("", 6666);  // btw fixed the quote marks for you

// now the Server object points to 6666
// but the old server process is still listening on 57110


reboot will try to quit the server process – but it’s forgotten about port 57110. It will send /quit to port 6666 – so the old process won’t get the message and it won’t shut down.

Then it will boot a new process on 6666.

It’s probably ok in your case because the first boot attempt failed – but a better habit when changing a Server object’s NetAddr is to s.quit first, then change the address and boot.


1 Like