Impossible installation of PortedPlugins on a M2 Mac


I just replaced my old laptop for a MacBook Air M2 (Monterey 12.5), and I would like to install the PortedPlugins :

The plugins are for sure in the right Extensions folder but I get this message after compiling

*** ERROR: dlopen '/Users/Morton/Library/Application Support/SuperCollider/Extensions/MKPlugins/OscBank_scsynth.scx' err 'dlopen(/Users/Morton/Library/Application Support/SuperCollider/Extensions/MKPlugins/OscBank_scsynth.scx, 0x0002): tried: '/Users/Morton/Library/Application Support/SuperCollider/Extensions/MKPlugins/OscBank_scsynth.scx' (mach-o file, but is an incompatible architecture (have (x86_64), need (arm64e)))'
Found 0 LADSPA plugins

"mach-o file, but is an incompatible architecture (have (x86_64), need (arm64e)) "

Do you have an idea of how I can solve this ? I would really like to use them again on this new mac
Thanks a lot

The problem is that the plugins are compiled for the Intel chip, while your new Mac has and Apple (ARM) chip.
The best solution would be for @madskjeldgaard to update the plugins and offer universal binary (x86_64 and arm64 as one “universal” binary, or as two separate downloads).
If that’s not available, as a workaround you could run SuperCollider through Rosetta 2 - that way you’d run the Intel (x86_64) version of SuperCollider through an emulation layer. This will be a bit slower than running it natively. To do that, select “Get Info” in Finder for the, then check the “Open using Rosetta” box. Please note, that all your plugins need to be either universal binary or Intel binary in this case. Again, this is a workaround and will result in degraded performance.

I should update it at some point (otherwise I am super happy to receive pull requests!) Ported Plugins to reflect this.

Until then, you can use Plugins.quark to install it GitHub - madskjeldgaard/plugins.quark: A package manager for SuperCollider plugins

Side note, I noticed this when building plugins from the cookiecutter and your tutorial. It would be great if you could update the tutorial to reflect the need to CMAKE_OSX_ARCHITECTURES

Thanks - I’d be happy to receive a pull request :slight_smile:

I didn’t realize that was a repo! I’ll find it. Thanks Mads!

Thanks Mads and Marcin :slight_smile:

@Hobbes, did you manage to install PortedPlugins under osx ARM? I have been running under Rosetta for a long time, I think I got all the pieces to say goodby to Rosetta except Ported Plugins. I tried installing the Plugins quark but it does not seem to run under ARM. I am totally novice when it comes to building from source.

I’ve been running on arm for a bit. Try putting this in your extensions folder:

You will probably need to run:

xattr -rc “directory” on the directory before you boot the server.


Great, I got it working! Thanks for sharing