Improving MIDIInput on raspberry

Hello :wave:

I’m currently trying to use supercollider on a raspberry pi with simple midi keyboard attach to it. Problem is I have a lot of midi stuck notes and I know it’s not code related cause it’s working fine on macos. SC don’t even receive the appropriate note off event.

I think it’s driver related. But I saw also some working fine samplers on the internet…
Do you know a way to overclock midi events frequency on such a plateform ( linux, rapsberry…) ?

Not sure if this is related to your problem, but midi allows for two ways of specifying note off:

  1. using a proper note off message
  2. using a note on message with velocity 0

Maybe you need to take option 2 into account into your code?

With default settings, that should already be handled:*noteOnZeroAsNoteOff


1 Like