Input sampling rate does not match the output?


#1

I was exploring examples people posted using the Pluck Ugen, when suddenly I wasn’t getting any sound. I tried restarting supercollider and got this when I booted the server:

booting server ‘localhost’ on address: 127.0.0.1:57110
Found 0 LADSPA plugins
Number of Devices: 6
0 : “Built-in Microph”
1 : “Built-in Output”
2 : “Soundflower (2ch)”
3 : “Soundflower (64ch)”
4 : “ACE Sound Effects”
5 : “Loopback Audio”

ERROR: Input sample rate is 88200, but output is 44100. Mismatched sample rates are not supported. To disable input, set the number of input channels to 0.
could not initialize audio.
RESULT = 0

I have no idea how this happened, or how to fix it.


#2

Hi.
I don’t know why this happened. Maybe if you post the code that caused the error we could try to figure out.
In the meantime you could try to set the sample rate manually like this: s.sampleRate = 44100


#3

Have you tried going into System Preferences > Audio/MIDI Setup (assuming you are on a Mac), and fixing input and output sample rate there?

B