Install safety-limiter plugin error

Distributor ID: Debian
Description: Debian GNU/Linux 11 (bullseye)|
Release: 11
Codename: bullseye

I try to install the supercollider-safety-limiter found here: GitHub - nhthn/supercollider-safety-limiter: A zero-latency safety limiter for SuperCollider

My SC source is:
Platform.userAppSupportDir: /home/drumanart/.local/share/SuperCollider
Platform.resourceDir: /usr/share/SuperCollider

Then in the build directory I do configure cmake:
cmake … -DCMAKE_BUILD_TYPE=Release -DSC_PATH=/home/drumanart/.local/share/SuperCollider -DCMAKE_INSTALL_PREFIX=.local/share/SuperCollider/Extensions

and I get an error:

CMake Error at cmake_modules/SuperColliderServerPlugin.cmake:19 (message):
Could not find SuperCollider3 headers at

Please set SC_PATH to the root folder of the SuperCollider project relative
to the folder containing this CMakeLists.txt file
Call Stack (most recent call first):
CMakeLists.txt:29 (sc_check_sc_path)

– Configuring incomplete, errors occurred!



I do not recommend using SafetyLimiter anymore. I ran into cases where it sounds bad. I will eventually do a complete rewrite of it with lookahead support.

I would recommend the SafetyNet Quark from @adcxyz for this purpose. It’s super easy to use, and if for some reason you don’t like its built-in “safeties”, you can also register your own limiter, and it will instantiate them (on all reboots and after Cmd-Period).


1 Like

Not a solution, but related maybe. Routing into a DAW with a limiter on the master is what I’m doing. That may not be an option for your scenario, but sending separate channels into a DAW allows me hear how the mix will respond to limiter without actually limiting what’s recorded.

Ok I’ll give a try with SafetyNet