Installation Issue in Ubuntu 19.10

Hi - hope I’m in the right place to ask this, but I’ve been trying all afternoon to build SC in Ubuntu 19.10 (I’ve never had a problem in earlier versions). I’ve tried a number of times, and each time get dumped at the following error:

[ 65%] Linking CXX static library libsclang.a
[ 65%] Built target libsclang
Scanning dependencies of target sclang
[ 65%] Building CXX object lang/CMakeFiles/sclang.dir/LangSource/cmdLineFuncs.cpp.o
[ 66%] Linking CXX executable sclang
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/ undefined reference to `tgetnum@NCURSES6_TINFO_5.0.19991023'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/ undefined reference to `PC@NCURSES6_TINFO_5.0.19991023'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/ undefined reference to `tputs@NCURSES6_TINFO_5.0.19991023'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/ undefined reference to `UP@NCURSES6_TINFO_5.0.19991023'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/ undefined reference to `tgoto@NCURSES6_TINFO_5.0.19991023'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/ undefined reference to `tgetent@NCURSES6_TINFO_5.0.19991023'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/ undefined reference to `tgetstr@NCURSES6_TINFO_5.0.19991023'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/ undefined reference to `tgetflag@NCURSES6_TINFO_5.0.19991023'
/usr/bin/ld: /usr/lib/x86_64-linux-gnu/ undefined reference to `BC@NCURSES6_TINFO_5.0.19991023'
collect2: error: ld returned 1 exit status
make[2]: *** [lang/CMakeFiles/sclang.dir/build.make:119: lang/sclang] Error 1
make[1]: *** [CMakeFiles/Makefile2:3810: lang/CMakeFiles/sclang.dir/all] Error 2
make: *** [Makefile:163: all] Error 2

Appreciate this might not be the right forum, but would love for someone who’s more familiar/knowledgeable on the build process to point me in the right direction!

I have the same problem. It seems that it lacks some specific versions of libraries. Have you been able to solve it? Would be grateful for any tips. Thanks.

i am not a Ubuntu user, but it looks to me like either your version of libreadline is out of date, or libcurses, or possibly both. i would try upgrading both and rebuilding. and, if you don’t mind, note down the versions of both before and after for future readers.

I really had a hard time with this, with many wasted hours. I had originally upgraded to 19.10 from 18 (can’t remember which version, unfortunately) about a year ago. This was a problem then, but didn’t have time to track down. Made time now because I wanted to get SC working, but just couldn’t defeat this one. I tried updating libs, but they were always the latest anyway. I eventually just bit the bullet, did a fresh install of 19.10 and now it works. There must have been something askew in the upgrade path, but I couldn’t figure it out. Sorry that I don’t have a better answer…

No worries. Glad it’s working now! Perhaps @gangiman will have better luck

Ok. Thank you for a quick response. My Ubuntu 19.10 was also updated from 18.04, it’s gotta be some dependancy. Can you please share a list of all packages on your system? Want to compare with mine and see the difference in versions and missing packages. It’s an output of “dpkg --l” command.

@gangiman have you tried updating apt-get and upgrading the packages that provide libreadline and libncurses? i would start there first.

after another user encountered this on opensuse and submitted a bug report to github, i did some more digging and think i found the source of the problem. if anyone is running into this issue and has the time, can you please try my fix?