Installed quark, plugin not found

I’ve added git to the System Variables path (Windows 10) and verified that it’s in the path with

Git.checkForGit returns “True”

I tried to manually install a quark (PV_Control) using this statement:


and receive the following error when I try to run the SynthDef that contains PV_Control:

“exception in GraphDef_Load: UGen ‘PV_Control’ not installed.”

I’ve recompiled the library, closed/opened SC, used the GUI to install PV_Control, but nothing works. Help?

Welcome! I’ve moved this to a new topic, since it’s not really a Quarks problem.

Quarks don’t currently ship server-side plugin DLLs. The quark has given you the sclang class hook to be able to write the UGen into a SynthDef. You still need the compiled, binary plugin, which should be installed separately into your Extensions folder.


hjh - Thanks for your speedy reply.
Are there step by step instructions on how to compile the binary plugin for PV_Control?

When I use the cmake GUI to build PV_Control from its ‘source’ folder, cmake uses the file path of the guy that wrote the code (Sam Pluta) instead of my path on my computer. I don’t know from where cmake is reading the wrong path. Any ideas?

Hi. I am the culprit. To be clear, I don’t know how you build a UGen on Windows.

On Mac, you would erase the build directory and CMakeLists.txt file and follow the “Compiling” instructions from the start here:

But it explicitly states that the build system is missing in Windows, so I am not sure how to do it.


Hey Sam!
Thanks for chiming in. We had an exchange several years ago when I tried to implement PV_Control on a Windows 95 laptop. I never got it working, but I’m determined this time to make it work on my Windows 10 laptop. I understand that I can download Ubuntu and run it as a virtual machine. I’ll try that and use the instructions above.