Interfacing SC with vmpk

Hi all

I try to use vmpk as a MIDI controller for SC.
Once it worked. Tried all sorts of adjustments, but couldn’t manage to make it work.

Here a screenshot:

In SuperCollider I ran:




And it gives me this:

MIDI Sources:
	MIDIEndPoint("System", "Timer")
	MIDIEndPoint("System", "Announce")
	MIDIEndPoint("Midi Through", "Midi Through Port-0")
	MIDIEndPoint("SuperCollider", "out0")
	MIDIEndPoint("SuperCollider", "out1")
MIDI Destinations:
	MIDIEndPoint("Midi Through", "Midi Through Port-0")
	MIDIEndPoint("VMPK Input", "in")
	MIDIEndPoint("SuperCollider", "in0")
	MIDIEndPoint("SuperCollider", "in1")
	MIDIEndPoint("SuperCollider", "in2")

But I don’t receive any MIDI messages. Missing something obvious probably…


I’ve never used vmpk.

Try to see if, in vmpk, it will allow you to set as a destination , something you see in the sources list, for SC.

& instead of having to reboot your OS each time, you can try:


…before calling .init, to reset SC

1 Like


I can choose “SuperCollider (1)”, “SuperCollider (2)” or “Midi Trough” if I enable “Show Advanced Connections”.

But it doesn’t have any effect.
With my hardware Midi controller things are working without problems.

If you’re trying to use vmpk to control something in SC - you have your MIDI ins and outs reversed in vmpk.

You should connect Output MIDI Connection to SuperCollider(0) …or whichever one you prefer… instead.

The screenshot of your current MIDI preferences in that pop-up menu, you’re currently listening for MIDI signals coming from SuperCollider, and outputting MIDI signals to SonivoxEAS.

Also, if you want to control SC, you should likely turn disable that middle checkbox: Enable MIDI Thru on MIDI Output, just in case.

Hmm… sounds sensible. But for some strange reason I can’t choose anything different from the pop-up menu than SonivoxEAS for Output MIDI Connection.

For the MIDI OUT DRIVER I have the options:
SonivoxEAS, FluidSynth, Network and OSS. If I try to change that, vmpk freezes.

Unfortunately I’m not on a Linux build, so I’m not quite sure why that is. Certainly seems the issue is in vmpk, especially if it’s crashing.

Also odd that in the screenshot in your first post with all the patched up MIDI modules there is no VMPK output anywhere, just that through connection. Could it be that VMPK is just software for piano sounds, not a piano-style keyboard controller?

Yeah, would guess the problem is on VMPK side.

Actually I have used VMPK as a software MIDI controller before successfully.

Here it’s also mentioned as a possibilty (search for “vmpk”):

VMPK documentation discusses routing MIDI to and from it with either:

The command line utility “aconnect” allows to connect and disconnect the virtual MIDI cables between any ports, being hardware interfaces or applications. A nice GUI utility for doing the same is QJackCtl.

Maybe the port has to be ‘created’ first? Purely guessing at this point though as I’ve never used this software.

Those connections you saw in my first screenshot are in a software called “Cadence” which has more or less the same purpose as “aconnect” or QJackCtl.

When trying to monitor the MIDI messages with something else (kmidimon, aseqdump) than SuperCollider I don’t receive anything.

Will try to contact the VMPK developer(s).

So if anyone else using VMPK could reproduce the problem that would already be interesting for me.

edit: Problem was with something vmpk-related.