Linux/Jack: RME UCX II Can't Map Inputs

Any Linux SC users ever encountered an issue like this?
I’m able to get jack to recognize my RME UCX II but for some reason only the outputs and not the inputs.

jackd will complain:

Unknown source port in attempted (dis)connection src_name [capture_1] dst_name [SuperCollider:in_1]

and scsynth

JackDriver: couldn't connect  system:capture_1 to SuperCollider:in_1

I am starting jackd manually in a headless mode like this
JACK_NO_AUDIO_RESERVATION=1 jackd -d alsa -d hw:II24069494 -P -r 48000 -p 1024

I’m getting a little frustrated with the lack of Jack reference documentation.

scsynth is being starting like this:

#!/usr/bin/env sh
SC_JACK_DEFAULT_OUTPUTS="system:playback_1,system:playback_2,system:playback_3,system:playback_4,system:playback_5,system:playback_6,system:playback_7,system:playback_8,system:playback_9,system:playback_10,system:playback_11,system:playback_12,system:playback_13,system:playback_14,system:playback_15,system:playback_16,system:playback_17,system:playback_18,system:playback_19,system:playback_20" \
SC_JACK_DEFAULT_INPUTS="system:capture_1,system:capture_2,system:capture_3,system:capture_4,system:capture_5,system:capture_6,system:capture_7,system:capture_8,system:capture_9,system:capture_10,system:capture_11,system:capture_12,system:capture_13,system:capture_14,system:capture_15,system:capture_16,system:capture_17,system:capture_18,system:capture_19,system:capture_20" \
scsynth \
-t 57100 \
-B \
-m 1052672 \
-i 20 \
-o 20 \
-l 2

if you are stuck with a jack-related problem on linux i guess the best place to ask for support would be the linux-audio-users mailing list. Linux-audio-user Info Page

Do the jack inputs appear in something like qjackctl? If not, sometimes it helps to manually specify the number of inputs when you start jack. I don’t know the flag off-hand, but qjackctl has a nice setup page for it.

What I ended up having to do was to explicitly pass the input arguments to the alsa master using the -P and -C flags. My jackd command now looks like this:
JACK_NO_AUDIO_RESERVATION=1 jackd -R -d alsa -P hw:1 -C hw:1 -D -r 48000 -p 1024 -n 2

This solves my issue of not being able to map and access the hardware inputs. A test with { }.play works.

I have a somewhat different issue now which is that when I enable the hardware capture devices, I am unable to read from virtual audio buses without getting garbled noise. Does anyone know why this might be. I am experimenting with the -a,-i, and -o flags to no avail.

This definitely seems like more of a SuperCollider issue than a jack one.