Mac testing: '.load' a specific file

Ddwchucklib does not work on a mac computer - #11 by jamshark70 is troubleshooting a problem where a specific scd file in a quark isn’t being .load-ed, on Mac. I can’t reproduce it in Linux, and I’ve loaded ddwChucklib-livecode successfully in Windows before, so it seems to be a Mac issue.

Would some other Mac users mind running a brief test for me?

  1. Quarks.install("ddwChucklib-livecode") (assuming you have git all set up). (There are several dependencies here, but you can’t quite do without them for the test, sorry.)
  2. Recompile the classlib.
  3. ("ddwChucklib-livecode").localPath +/+ "mobile-objects.scd").load;

Good result would be -> PR('controlList').

Bad result would be the path to the file.

Thanks –

I am using macOS 14.5 (m1 max), and I got the following error:

ERROR: Class not defined.
  in interpreted text
  line 1281 char 41:

  				if(ctls.isKindOf(ValidatingDictionary)) {
  					ctls =;
-> nil

I have tried to find ValidatingDictionary in all the Quark directories on my machine:
/Users/prko/Library/Application Support/SuperCollider/downloaded-quarks/

I see only three occurrences of ValidatingDictionary in the following file:

  • two occurrences in /Users/prko/Library/Application Support/SuperCollider/downloaded-quarks/ddwVoicer/
  • an occurrence in /Users/prko/Library/Application Support/SuperCollider/downloaded-quarks/ddwChucklib-livecode/mobile-objects.scd

However, I cannot find the definition of ValidatingDictionary.

Good catch – there were some changes in ddwCommon that I hadn’t pushed to the public repository.

If you update the ddwCommon quark from github, it should be ok now.


After evaluating{|quark| quark.update() }, I reevaluated ("ddwChucklib-livecode").localPath +/+ "mobile-objects.scd").load;, and got:

-> PR('controlList')

It seems to be worked!

OK, thanks!

That suggests another possible cause for the issue in the other thread. Might be helpful to have more data points (other people testing) but this might explain it.