Manjaro / Arch dwm and resolution

I’m setting up a Linux laptop running Manjaro with Larbs and dwm as a window manager. Recently (i believe after updating to the latest version) i’ve had issues with SCIde windows not adapting to the dwm window. When typing text it looks like small dots (maybe a font size of 1 px or something) and the menus are almost unreadable with text disappering when selecting. I tried to open the userAppSupportDir from the filemenu and then it says ‘broken’. After investigating this it seems i have directories at




So that seems ok. And if i run sc in an Xfce4-session instead it seems to work fine, so it’s only happening when running dwm only. All other applications adapts to the size of the dwm as far as i’ve tried. So, what could be special with SCIde in this regard? What to check?

After investigating further it seems to be related to my GPU. If i start sc from the terminal with

$ prime-run scide

It works. So, probably this occured when i tried to get my hdmi port to work the other day. I had to set the GPU to be active all the time for it to work.
But why is it only scide that behaves like this?

EDIT: Nah… after a reboot it looks like crap again even with prime-run. Any help from Linux users welcome.

So, for the record, and if anyone else run into a similar problem i think i have solved this now by setting this variable in /etc/environment:


Apparently, if this variable is unset (which it was), it’s a bit random how programs deals with scaling. At least according to this rant.

With this set to 0 everything works as it should.

1 Like