Missing examples


I recently started using Big Sur and so upgraded the SC version to 3.11.2. However, strangely enough when using Cmd + D, the examples in the Help files are missing (see screenshot) - the help file appears with the main information, but the examples space is completely empty! Has anyone else come across this, and what’s the problem/solution?

Thanks in advance.

That’s so weird, I’ve recently installed 3.10.0 on Linux and just noticed exactly the same problem.

1 Like

But 3.11.2 on the mac is fine for me.

1 Like

Well Ted, are you using Big Sur, and if so, maybe you’ve done something that I forgot to do?

Actually, my question should be, what OS are you using? I see it’s possible to update to 3.11.2 on other Mac OS, which may well work, but I’d be curious to know if anyone out there is using Big Sur and what they’re getting. I surely can’t be the only one with this problem?

Lastly, I installed an earlier version 3.9.3 to see what happens, and that works fine - with the examples I mean.

Any suggestions greatly appreciated.

just chiming in to say that i’ve got big sur on an m1 mac running 3.11.2 without this issue.

did you upgrade to big sur after installing 3.11.2?

the strange thing is, if i’m not mistaken, is that that the code examples should be in the same file.

what if you click and open the help file source at the bottom right of the help browser?
do you see code examples in the schelp file?

Thanks, I had thought to ask this, but forgot. But, to answer your question, no, Big Sur first, SC second. Secondly, I’ve tried to click on the source, but I just get:

Cannot open: /private/var/folders/zp/p8w_6whn0bs0p4w6c_nq5_0c0000gn/T/AppTranslocation/6971658D-

If they’re not they’re I guess I can go and get them from Git (but what do I need to fetch/download)? To be clearer, should they be put into the Application Support folder, or in the Applications file (package contents)?

Thanks in advance.

p.s. At the moment I don’t see them in either.

Okay, just to comeback once more - the examples are there (where they should be Applications/SuperCollider/SuperCollider.app/Contents/Resources/etc), but as you can see from my above reply, SC doesn’t seem to be looking for them in the right place (or … ?).

What I get at the bottom of my Help window (in full) is:


Can someone help me sort out the problem, please?

Thanks again.

Okay, just to say the issue has been solved, there seemed to be a conflict in the ~Library/Application Support/etc .... files. With a little help from the Git team I cleaned up my Supercollider folder, restarted and - at present - everything seems to be back to normal.


I had a similar conflict occur, though the examples still showed, but I wasn’t able to open any of the source files.

How did you fix it? For me, I deleted the SuperCollider folder in Application Support also the program from Applications - basically a clean install. I made a back up of my quarks, extensions, and config files before doing this, and just stuck everything back in place. That cleared everything up.

Hi @thresholdpeople, I did exactly the same as you.

Luckily, since this happened when I was changing computers, I hadn’t actually moved all my old stuff and naturally nothing to save. I just deleted (actually renamed) my old file in Application Support and like you, everything was back to normal.