PortedPlugins (formerly MKPlugins): Server plugins ported from elsewhere

Released 0.2.4 which adds VadimFilter - Virtual analog low pass, high pass and band pass filters based on the ground breaking work of Vadim Zavalishin. Ported from folderkit. Download prebuilt versions here:

1 Like

I would like to change the name of the repo. But what should we call it ? Join the discussion here: 📢 Let's decide on a new repo name · Discussion #20 · madskjeldgaard/mkplugins · GitHub

hi everyone, the plugins seems really cool, I followed the installing instructions from

but, using mac, after drag and dropping the cmake app into the application folder i cannot run the cmake code for the part :

cmake … -DCMAKE_BUILD_TYPE=‘Release’ -DSC_PATH=/path/to/sc/source -DCMAKE_INSTALL_PREFIX=/path/to/extensions
cmake --build . --config Release
cmake --build . --config Release --target install

using the mac with the M1 chip I hope its not some compatibility issues.

thanks to anyone with a clue on the direction to go =)

ps: i am getting the ’ command not found: cmake’

This means only that you need to install cmake.

Or, if you already installed it, then its location on disk is not in your $PATH system environment variable.

hjh

thanks James, I am investigate where is this path ^^

In the terminal:

Read the path:

echo $PATH

-> /home/xxx/.local/bin:/usr/local/sbin:/usr/local/bin:... etc.

Append a new path at the end of the existing paths:

PATH=$PATH:/some/other/path/with/binaries
export PATH

You might not need “export” but I think it doesn’t hurt to do it.

So then you just need to find where cmake is installed, and put the folder into the PATH.

hjh

good news I thinks it ended up working without using cmake but I will try your instructions, thanks heaps !

Good to hear. How did you end up making it work ? I am getting some questions on M1 Mac stuff but I don’t know anything about it unfortunately. The pre built ones for macOS don’t work ? Thanks for the help

I ll provide more details later but nothing i followed the instructions from the links until the cmake codes and stopped, restarted it didnt work and later doing another restart i got several notifications mentionning the firewall or vault and i did accept each module in the security settings and i ran ronds and another one and it seemed to work at least no more error syntaxes but i think it worked but again i ll double check in a bit

1 Like

I’ll soon update the repo with a new name and couple of new, very awesome plugins. But in the meantime, I have added some documentation on how to contribute to the project if anyone out there should feel curious enough to help out:

Ideas for new plugins to port

I’ve started a thread here in the discussions forum for the repo where you can post links to things that would be fun to port to SuperCollider. Feel free to add if you’ve seen anything interesting lately:

2 Likes

regarding M1 Mac, I just found out that if you are running SuperCollider under rosetta2 (ie the prebuild download version) and you want to build MKPlugins from source you need to explicitly set architecture to x86_64 as a cmake flag, like this:

mkdir build
cd build
cmake .. -DCMAKE_BUILD_TYPE='Release' -DSC_PATH=/path/to/sc/source -DCMAKE_INSTALL_PREFIX=/path/to/extensions --DCMAKE_OSX_ARCHITECTURES=x86_64 ..
cmake --build . --config Release
cmake --build . --config Release --target install

otherwise the plugins refuse to run.

1 Like

Thanks for the report :+1:

1 Like

v0.3.0 is out

This is a huge release adding 6 new plugins, fixing bugs and documentation ++++ new name. The project is now called PortedPlugins in the hope that it in the future will become more of a community effort.

See the changelog for more info and download precompiled binaries here:

2 Likes

Arch and Manjaro users

The arch package on AUR has been moved. To get the latest releases from now on, you need to install supercollider-portedplugins:

paru -S supercollider-portedplugins

1 Like

Release 0.3.0 includes 5 new virtual analog filters that are simply AMAZING. Here’s a short demo

8 Likes

Great stuff! I need to try those filters :slight_smile:

I’ll 3rd or 4th the comments on the VA filters – there’s some issue yet with frequency scaling (VADiodeFilter, write freq * 0.460829, VAKorg35 and VALadder, write freq * 0.33333) but I am getting some exciting, fun squeeky squelchy sounds out of them. A year or two ago I integrated Rack into my setup, especially because of the Vult filters… seems less need for that now.

Great stuff!

hjh

2 Likes

Thanks a lot for your feedback james. I don’t have an immediate idea about why those frequency params are scaled this way. Will have to look into the Surge synth source again probably to find the answer.

Also, it seems the filters are gained up a lot by a hardcoded default (3x) which I think should be a user settable param as this makes it very distorted by default.

Let me know if anyone wants to contribute a PR for any of this

Coming back to this after awhile… the built-in distortion is good to be aware of, but when you want to bring the filth, you kind of need it. Here’s VALadder getting nasty (sharing video just in case it isn’t fully appreciated how naughty these filters sound).

They’re a bit CPU-heavy (about 2.5% CPU per instance on my machine) but when you need dirt, RLPF just ain’t gonna cut it like this.

hjh

2 Likes