Qt5 install problem ubuntustudio 22.04

I’m trying to install SC on UbuntuStudio 22.04, and am stuck on some sort of QT5 problem. These are the instructions I am trying to follow:

https://github.com/supercollider/supercollider/blob/develop/README_LINUX.md

Dependencies all look good, but but I think the problem is related to QT. According to my ‘about’ dialog I have QT 5.15.3. I’m assuming therefore that I don’t have to try to install anything?

When I get to the instructions about setting compiler flags and try this:

cmake -DCMAKE_BUILD_TYPE=Release ..

I get a big red error:

  By not providing "FindQt5.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "Qt5", but
  CMake did not find one.

  Could not find a package configuration file provided by "Qt5" (requested
  version 5.7) with any of the following names:

    Qt5Config.cmake
    qt5-config.cmake

  Add the installation prefix of "Qt5" to CMAKE_PREFIX_PATH or set "Qt5_DIR"
  to a directory containing one of the above files.  If "Qt5" provides a
  separate development package or SDK, be sure it has been installed.
Call Stack (most recent call first):
  lang/CMakeLists.txt:184 (include)

There are instructions about non-standard QT in the read me, I suspect that may be the problem:

https://github.com/supercollider/supercollider/blob/develop/README_LINUX.md#nonstandard-qt-locations

This looks straightforward, I have to set a flag to point to the location of qt5. But how do I know what that is? I tried locate -b qt5 which produces hundreds of results. Ones that look promising include /usr/lib/qt5 and /usr/share/qt5 – try one of those?

Or… am I completely missing something? Do I still have to install something? I tried this, from further up the readme:

sudo apt-get install qt5-default qt5-qmake qttools5-dev qttools5-dev-tools qtwebengine5-dev libqt5svg5-dev libqt5websockets5-dev

but that throws this error:

Package qt5-default is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'qt5-default' has no installation candidate

Er, help!

Ok, if anyone else hits this problem, the answer is here :slight_smile: