Really n00b question

I’m sorry for asking such a dumb question, but I had to reboot my computer and now all the work I’ve done in supercollider is inaccessible to me. I’ve tried uninstalling and reinstalling, no joy. I think it’s scide that needs to be run, but I can’t find that anywhere. I feel sad and alone, can anyone help me? (ETA: Windows 11)

If you mean you crashed and had to reboot WITHOUT saving… USUALLY the SuperCollider IDE would tell you on launch that you had unsaved files and blah blah blah Do You Want To Restore Them? Of course in this case you need to choose the Yes option, otherwise the backup files will be deleted.

If you crashed / force-rebooted and DIDN’T see this message when you launched — I’m not really sure how that could happen, but of course it’s possible… in that case, you probably lost anything you didn’t save. Sorry about that - but don’t be too discouraged, it’s happened to all of us many many many times. You’ll be able to built whatever you had again - and the second time you built it, it will be different but better because you’ve learned things since the first time. Mostly you end up having to choose for yourself to rebuild something to be better - sometimes your computer chooses this option for you :slight_smile:

If you’re just having a problem where you can’t find the SC ide to re-launch it — tbh I have no idea where it’s installed on Windows, but it should be somewhere in c:/Program Files/ or findable via normal windows app search / execution methods? But maybe someone with more Windows experience knows better here…

Thanks so much. I’ve fixed it now! I did not lose anything, frabjous day, coolah, coolay!
Still not sure what happened but I uninstalled, rebooted and then reinstalled and now we have flying unicorns and rainbows again.
I thiiiiink maybe there was a cheeky instance of the IDE still running somewhere in the background that was preventing it from restarting. But it did not show up in the task view. Rebooting cleared it, and I did get a “did not shut down properly” message when I started it up again. No matter, it’s running again. Nothing lost.

lol was talking to IT friends and they were like, dafugg is SuperCollider? Are you a physicist now? (ETA: Also I got a lecture about not installing dodgy stuff on my computer.)

Glad it’s fixed. You can tell them that SuperCollider isn’t dodgy, and then play them some really abrasive music you composed with only sine tones and the WhiteNoise UGen, and then they’ll for sure never ask you about it again. This works great for me.


This is the correct answer.