Requested sample rate was not available


I seem unable to be able to change the sample rate on Supercollider using the s.options.sampleRate = 44100; instruction.

When i do this and reboot I get the message.

Requested sample rate 44100.000000 was not available - attempting to use sample rate of 16000.000000
“EDIFIER X3 L” Input Device
Streams: 1
0 channels 1

I am using bluetooth headphones. Could this be part of the problem?


Yes. The output on the headphones is likely able to have a sample rate of 44100, but the input probably cannot. Change your system input to the computer microphone or something else that can have a sample rate of 44100 and it should work. So, you would have the output be the headphones and input be the computer microphone.

If you are on a mac, you can check/change the sample rates of all devices in Audio MIDI Settings.


Legend, that worked. Thanks!