SC blocked loading library

Hi, I have a problem. After trying to uninstall (to reinstall) ddwGUIEnhancements quark using the Quarks.gui, SC just won’t open (completely) and remains blocked trying to compile the library. I’m getting this error message in the post window, the help window doesn’t even open:

ERROR: Superclass 'HJHObjectGui' of class 'MTGui' is not defined in any file.
/Users/admin/Library/Application Support/SuperCollider/downloaded-quarks/ddwChucklib/
ERROR: Superclass 'HJHObjectGui' of class 'MIDIRecGUI' is not defined in any file.
/Users/admin/Library/Application Support/SuperCollider/downloaded-quarks/ddwMIDI/
ERROR: There is a discrepancy.

I’ve tried opening SC via s.boot, but nothing happens. This means that I can’t get to the Quarks.gui to install the quark(s) mentioned. I see them in the Quarks folder in Application Support >> downloaded-quarks etc…, so where’s the problem? I’ve even tried re-installing SC thinking there might be an error elsewhere, but still no luck!

I include a screenshot just in case my explanation isn’t clear - as you’ll notice no help window, and sending request running (non-stop).


Big thanks in advance - Joe

Okay, problem solved by moving my downloaded-quarks folder out of Application Support >> SC >> downloaded-quarks. Then rebooting, and then manually reinstalling (dragging the folder back) again into the SC file. Seems to have solved the problem, although I can’t understand how, or why, it blocks you from updating the ‘offensive’ quark, most odd.

Oh well all’s well that ends well.

1 Like