Server doesn't boot under Windows 10

Hey SC Community.

I recently installed SuperCollider-3.10.4 under Windows 10. When I execute s.boot; I get the following output:

-> localhost
Booting server ‘localhost’ on address
Server ‘localhost’ exited with exit code -1073741786.

Nothing else…
Does anyone know how to solve that issue?


There’s one known issue referring to that error code:

Are you using Jack in Windows, by any chance?



Oh yes I think that was the problem. I had Jack istalled once, but I didn’t uninstall all the components properly. Now I did and SC works, thank you!!

Thanks for this thread! I was going nuts troubleshooting a Win 10 machine. I was reading the github issue page that James shared above, and scrolling way down I found the workaround that worked for me. I just wanted to highlight it here in case it’s useful for others:

It involves disabling some security thing in your Windows Defender Security Center, if you are OK with that.

After following those steps and restarting the computer, now my SC 3.11 64-bit install boots the server normally.


I have this same problem but I’ve never installed Jack on my computer.
The closest thing I have to jack is a .cpp file for it that came with the VST3 SDK but it’s not even compiled.
I don’t understand why I’m not able to boot SC server.

If you don’t have jack then maybe it’s a different issue.

  1. what’s your error message?
  2. which SC version?
    2a. have you tried the “bleeding edge” build?

the security thing bruno mentioned above is windows security > virus and threat protection > virus and threat protection settings / manage settings > exclusions / add or remove exclusions > add scsynth.exe as a process to the exclusions. server should boot.

error message is:

SCDoc: Indexing help-files…
SCDoc: Indexed 1345 documents in 1.07 seconds
Booting server ‘localhost’ on address
Exception in World_New: boost::interprocess::intermodule_singleton initialization failed
Server ‘localhost’ exited with exit code -1073741819.

I was running 3.11.2 64 bit. Then I uninstalled and reinstalled. Then I uninstalled and installed 3.10.4 64 bit. Then I uninstalled and installed both of those versions as 32 bit and it still doesn’t boot. I also tried uninstalling and reinstalling and deleting local appdata for supercollider.

Also tried disabling all antivirus stuff. Checked task manager and there’s no other instances of sclang or the server. Tried killing all servers, rebooting interpreter etc

I’ll try the dev build and let you know how it goes. Supercollider was running just fine until a few weeks ago. I was working on projects with it 3 months ago and took a break. Haven’t done anything to any of the files or added anything to my machine that might interfere with it to my knowledge and then I opened it up a few weeks ago to start back where I left off with some projects and it won’t boot.

All I can guess is maybe it was a random windows update that did something? I run steam and epic games and those are always running in the background keeping the local service host busy, maybe they’re creating some kind of interference? IDK

Anyway, I’ll update later. Thanks!

I run Norton so windows security scans are disabled to allow Norton to do the heavy lifting.
I’ll try and find a similar option in Norton, but it didn’t have a problem with supercollider before.