ServerMeter not starting

Can anyone think of a possible reason for this strange behaviour? I recently purchased a new iMac (refurbished 2020 model running OS 11.6.8), and for some reason the server meter does not start (on the new machine only— it is still fine on my laptop). I.e., when I run the following simple test, the meter view does appear but the level indicators remain at zero, and on the node tree display I do not see the two new nodes being created which normally would appear when the server meter is started. I also don’t see five new UGens added to the status bar as I normally would:


When I then close the meter window, I get two failure messages indicating that SC is trying to free two nodes that don’t exist. At the suggestion of someone on the SC Facebook group, I tried dumping OSC messages and verified that when I create the ServerMeter the following OSC messages are sent:

[ “#bundle”, 16653446281817168595,
[ “/d_recv”, DATA[395], DATA[48] ],
[ “/d_recv”, DATA[381], DATA[48] ]

I’ve also verified by the following test that there doesn’t seem to be a problem with sending amplitude and peak levels and monitoring them with a separate LevelIndicator:

// Try multiple meters on a display
var sound, buf,win, meters,resp;
buf =, Platform.resourceDir +/+ “sounds/a11wlk01.wav”);
// produce sound
sound = {
var sig, pan, colum;
pan =; //oscillating pan
colum =, b,, loop: 1);
sig =,pan,0.5);{arg i;[i],10,3,‘/levels’,i);});
// Create a window with meters on it
win = Window(“meters”,Rect(100,100,200,300)).front;
win.view.decorator = FlowLayout(win.view.bounds, 10@10, 20@5);
meters = Array.fill(2,{LevelIndicator(win,15@200).drawsPeak_(true);});
// Create responder function
resp = OSCFunc({arg msg;
var ind;
ind = msg[2];
meters[ind].value = msg[4].ampdb.linlin(-40, 0, 0, 1);
meters[ind].peakLevel = msg[3].ampdb.linlin(-40, 0, 0, 1);
}, ‘/levels’, s.addr);


The above code gives me two level indicators functioning as expected.

Any idea what might be causing the meter to fail to start? I have not yet noticed any other problems with SC on the new machine: sound is coming out just fine and everything else I’ve tried seems to work as expected. But this issue has persisted after rebooting the server, the whole IDE, and even the machine multiple times. It doesn’t appear to make a difference whether I use s.meter or directly create a MeterView inside another window.