Visualising the levels of assigned audio buses


#1

I have allocated a few Bus.audio(s,2) (for example ~ch_kick = Bus,audio(s,2); = (Bus #4 in this example). I start to play a stereo kick synth outputing to ~ch_kick). I play a second synth that simply take input from ~ch_kick and outputs to 0 (my default audio out). I added it using .addAction: addToTail). I can hear the kick playing.
BUT nothing shows up on the 4th channel of the s.meter(numOuts: 32). I can only see the audio levels of bus 0 and 1. It doens’t seem to be a faulty install, as I asked Eli Fieldsteel on one of his videos and he was able to reproduce the issue.
Is there a way of visualising the audio levels of the audio buses that we have previously assigned?

It seems to be possible using the LevelIndicator, but would require some code unrelated to the music that is being created, effectively making the code less readable.

Thanks for any input, as having new keywords to search always helps learning a bit more about supercollider.


#2

Hey and welcome to the community !

Have you tried setting the number of outpus channels of your audio interface before booting the server ?

Something like

s.options.numOutputBusChannels = 4; // 4 output channels in your soundcard
s.options.numInputBusChannels = 2; // 2 input channels
s.boot; // boot the server

If it does not work, can you post your complete code so we can investigate ?

best

geoffroy


#3

Unfortunately, the server meter backend will monitor only hardware input and output busses.

I think that’s not a very good restriction, so I’ve filed an issue for it.

In the meantime, you could install the ddwPeakMonitor quark. If you’ve installed git (the component that downloads quark extensions for you), then you should only need to do:

Quarks.install("ddwPeakMonitor")

If that doesn’t work, post back here and we can help you install it manually.

Then you can do:

PeakMonitor(4)  // monitor 2 channels starting with 4

// or
PeakMonitor(Bus(\audio, 4, 8, s))  // 8 channels

hjh


#4

Hi and thanks!
I have tried setting s.options.num*BusChannels as you suggest, but it doesn’t seem to solve the problem.


#5

Ok thanks for the precise answer.
I have installed the ddwPeakMonitor, and it works. It does the job, but I agree with your github issue; it would be intuitive to have the AudioBuses also included in server meter.
Thank you all for your help; I’ll marked it as solved; as the conclusion seems to be server meter does not do that yet.