Why is my basic sine wave discontinuous? Server issues?

Hi everyone! New user here, new to SC, excited to see what this community’s all about :slight_smile:

I’m having trouble establishing a basic sine wave - I boot up the server, type in {SinOsc.ar}.play; execute the code and… And then my sine wave sputters awkwardly and the percents next to my server read a ridiculously large number:

I presume those percents should be far lower… What’s my next step here?

Thanks so much!!! <3

Here’s my post window:

	Found 845 primitives.
	Compiling directory '/usr/share/SuperCollider/SCClassLibrary'
	Compiling directory '/usr/share/SuperCollider/Extensions'
	Compiling directory '/home/[name]/.local/share/SuperCollider/Extensions'
	numentries = 819910 / 12168006 = 0.067
	5437 method selectors, 2238 classes
	method table size 13245656 bytes, big table size 97344048
	Number of Symbols 12276
	Byte Code Size 368207
	compiled 318 files in 1.78 seconds

Info: 4 methods are currently overwritten by extensions. To see which, execute:
MethodOverride.printAll

compile done
localhost : setting clientID to 0.
internal : setting clientID to 0.
Couldn't set realtime scheduling priority 1: Operation not permitted
Class tree inited in 0.04 seconds


*** Welcome to SuperCollider 3.10.0. *** For help press Ctrl-D.
Couldn't set realtime scheduling priority 1: Operation not permitted
SCDoc: Indexing help-files...
SCDoc: Indexed 1349 documents in 2.0 seconds
Booting server 'localhost' on address 127.0.0.1:57110.
jackdmp 1.9.12
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2016 Grame.
Copyright 2016-2017 Filipe Coelho.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 10
self-connect-mode is "Don't restrict self connect requests"
audio_reservation_init
Acquire audio card Audio0
creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 16bit little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 16bit little-endian
ALSA: use 2 periods for playback
JackDriver: client name is 'SuperCollider'
SC_AudioDriver: sample rate = 48000.000000, driver's block size = 1024
JackDriver: connected  system:capture_1 to SuperCollider:in_1
JackDriver: connected  system:capture_2 to SuperCollider:in_2
JackDriver: connected  SuperCollider:out_1 to system:playback_1
JackDriver: connected  SuperCollider:out_2 to system:playback_2
SuperCollider 3 server ready.
JackDriver: max output latency 42.7 ms
Requested notification messages from server 'localhost'
localhost: server process's maxLogins (1) matches with my options.
localhost: keeping clientID (0) as confirmed by server process.
Shared memory server interface initialized
-> Synth('temp__0' : 1000)```




**Executing MethodOverride.printAll gives me:**




```Overwritten methods in class library:
-------------------------------------

Meta_MIDIClient
---------------
	Meta_MIDIClient:externalSources
		/usr/share/SuperCollider/SCClassLibrary/Platform/linux/SystemOverwrites/extMIDIOut.sc
		/usr/share/SuperCollider/SCClassLibrary/Common/Control/MIDIOut.sc
	Meta_MIDIClient:externalDestinations
		/usr/share/SuperCollider/SCClassLibrary/Platform/linux/SystemOverwrites/extMIDIOut.sc
		/usr/share/SuperCollider/SCClassLibrary/Common/Control/MIDIOut.sc
	Meta_MIDIClient:getClientID
		/usr/share/SuperCollider/SCClassLibrary/Platform/linux/SystemOverwrites/extMIDIOut.sc
		/usr/share/SuperCollider/SCClassLibrary/Common/Control/MIDIOut.sc

Meta_MIDIIn
-----------
	Meta_MIDIIn:connectAll
		/usr/share/SuperCollider/SCClassLibrary/Platform/linux/SystemOverwrites/extMIDIOut.sc
		/usr/share/SuperCollider/SCClassLibrary/Common/Control/MIDIOut.sc

-> MethodOverride```
2 Likes

Couldn’t set realtime scheduling priority 1: Operation not permitted

You need to be a member of the audio user group.

There are many online pages about setting up a Linux system for real-time audio usage. Here’s one: https://jackaudio.org/faq/linux_rt_config.html

Unfortunately in Linux you can’t simply install and run. You have to configure the OS first.

hjh

1 Like

Thank you so much!!! :slight_smile:

I’ll look into this, really excited to get it working!

Okay I tried following that guide but I’m still getting the same error. I edited the file like so:

And then for the 2nd step I used this command:

sudo /usr/sbin/usermod -a -G audio username (with my real username, of course).

Where do I go from here? Thank you again @jamshark70 or your help, I recognize this is a very 101 question for an advanced forum.

Hm, I don’t know. The file looks correct, and the command looks correct too (though the page also mentions running a sudo groupadd – I’ll assume you did that, but not stated here, so I’ll mention it anyway).

Logout/login is necessary for it to take effect.

Unfortunately, I don’t have any other advice. The last time I installed a Linux system was 2.5 years ago, and that was Ubuntu Studio (which pre-configures RT priority for Jack)… so it’s probably been 4-5 years since I’ve had to touch user groups directly (and at that time, it just worked – though I could never get the interrupt priorities right in vanilla Ubuntu).

There’s a linux-audio-users mailing list, or a forum at http://linuxmusicians.com/ – people there will have more expertise.

hjh

Yeah I used sudo /usr/sbin/adduser/ audio, and when I executed the command again right now (to double check) it tells me adduser: The group `audio` already exists

Did this as well!

I’ll definitely check out the forum and hope for better luck, thanks again :slight_smile: I still very much appreciate you taking out your time to help a newbie!