nuPG: How to install?

Hello all

Fairly new Supercollider user here. Deep into synthesis but mostly with MaxMSP and analog. I want to install nuPG or the ‘The New Pulsar Generator’ from Marcin’s github… but he only left the source code… and no instructions on how to install?

Find it here: https://github.com/mpietruszewski/nuPg

I’m not up on how you compile all this code to make it run in the GUI its supposed to within Supercollider… I understand this might be super easy(or hard idk?) to execute for the average user but I’m just getting into SC and could use some help.

Anyway if anyone can explain to me how to get the nuPG gui running within SC from the source code, will certainly make my day…

Hi, you need to write Marcin directly to get a copy of NuPG. The current Github repo is incomplete so you won’t have much luck getting it to run in it’s current state.

Oh! I did not know this - Yeah I wrote him just haven’t heard back yet ::::sigh::::

Also noticed this on github - https://github.com/x75/nupg-lfs

Seems like a complete version (With linux install instructions?) posted by another user in Dec’ 2020. I run on Mac OS. Can anyone confirm if this version runs on Mac and if so same question as first post? I’m assuming install instructions is slightly different than in the READ ME file this user posted for linux…

Unless there’s something in the .sc code itself that isn’t cross-platform, I don’t see anything limiting about using those installation instructions on macOS. And given this line from the readme:

nuPg is distributed as SuperCollider Standalone App for Mac

I would say there is a pretty good chance the .sc code is intended to run on macOS. You will want to have git-lfs and rsync installed if you follow those instructions; you can get both via homebrew.

Welp did the install - not sure what I was expecting - the GUI loaded up but it seems like half of it is missing - got the startup sound to play from it but the sliders don’t do anything and none of the presets loaded up either… Not sure where I went wrong on the install if I even did but just followed step by step and this is what it came out as:

not at all the same as:

Pretty much given up unless somebody else has any ideas or maybe tried this themselves successfully… Maybe marcin will get back to me soon and I won’t have to worry about it… Thanks for the input thus far

Yeah sorry but you’re not going to get it to work as is. There are a bunch of crucial files missing from that repo at the moment, so don’t bother. Also, the linux build won’t work on MacOS for obvious reasons.

I sent you a DM with a solution that might help.

Hello.
I had contacted Marcin on two different platforms months ago but never heard back from him, unfortunately.
I guess the repo from this other user wouldn’t work on Windows, even if it were complete?
Can anyone tell me?

Thank you very much.

No, neither of the two repos on GitHub would work on Windows. There is a build for Windows but it is not publicly available yet.

I tried to install this on Linux, but ran into trouble with Conductor. (Full error message here if you’re interested.) According to this post, Conductor doesn’t work on SC 3.11 (I’m on 3.11.1).

However, from the Github readme: “Good news: working, in both nuPg versions 1.0 and 2.0 and in SuperCollider versions SC 3.9 and SC 3.11.” So I don’t know how he got Conductor working with 3.11.

I asked Oswald about it, but haven’t made progress. If anyone uses SC 3.9 or 3.10, you might be able to run this.

I would LOVE to get this going on Linux, so I’d super appreciate any advice.

hey there, I am still to update the github repo - sorry, I am bad at maintaining it.

The Conductor Class needed a small adjustment to work. I will upload it all into the repository soon too.

m

5 Likes

Hi hi!, I am very interested in trying it out. Thank you! and nice job

same problem with Conductor Class like “secretrow” on linux here.
conductor throws aleady while installation:
“ERROR: Message ‘tabletSlider2D’ not understood.
RECEIVER:
class QtGUI (0x563bbd660d40) {”
same problems also on sc3.9.3 on my raspberry pi3 (stretch)

maybe you could share your conductor adjustments here ?

thank you !

1 Like